2012年8月7日火曜日

coreserver で gem の更新

前回、coreserverのrubyを1.8.7にアップデートしました。
これならgemのアップデートが出来るだろうとチャレンジしてみたんです。

gem update --system
pdating RubyGems
Updating rubygems-update
ERROR:  While executing gem ... (Gem::InstallError)
    rubygems-update requires Ruby version >= 1.8.7
やっぱり怒られます。

gemの環境を確認します。
gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.1
  - RUBY VERSION: 1.8.5 (2006-12-04 patchlevel 2) [i686-linux]
  - INSTALLATION DIRECTORY: /virtual/***/lib/ruby/gem
  - RUBYGEMS PREFIX: /virtual/***
  - RUBY EXECUTABLE: /usr/local/bin/ruby
  - EXECUTABLE DIRECTORY: /virtual/***/lib/ruby/gem/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-linux
  - GEM PATHS:
     - /virtual/***/lib/ruby/gem
     - /virtual/***/.gem/ruby/1.8
     - /usr/local/lib/ruby/gems/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://gems.rubyforge.org/
どうやらruby1.8.5で認識されている様子。


それもそうですよね。
ruby1.8.5の時にgemをinstall しているんだから。


ってわけで、gemを再度入れ直します。※詳細はこちら
cd rubygems-1.3.1/
ruby setup.rb config --prefix=$HOME
完了したらgemを確認
gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.1
  - RUBY VERSION: 1.8.7 (2012-06-29 patchlevel 370) [i686-linux]
  - INSTALLATION DIRECTORY: /virtual/***/lib/ruby/gem
  - RUBYGEMS PREFIX: /virtual/***
  - RUBY EXECUTABLE: /virtual/***/local/bin/ruby
  - EXECUTABLE DIRECTORY: /virtual/***/lib/ruby/gem/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-linux
  - GEM PATHS:
     - /virtual/***/lib/ruby/gem
     - /virtual/***/.gem/ruby/1.8
     - /virtual/***/local/lib/ruby/gems/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://gems.rubyforge.org/
ちゃんとruby1.8.7として認識されたので gemをアップデートします。
gem update --system
Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.8.24
:0:Warning: Gem::SourceIndex#search support for String patterns is deprecated
Updating RubyGems to 1.8.24
Installing RubyGems 1.8.24
RubyGems 1.8.24 installed
正常にアップデート出来たら完了です。